Como saber que version de Bluetooth soporta mi equipo Linux

La tecnología Bluetooth ya lleva su tiempo en funcionamiento al momento de escribir esto ya contamos con la version 5.0, de hecho todas las versiones disponibles son las siguientes: 1.0b, 1.1, 1.2, 2.0, 2.1, 3.0, 4.0, 4.1, 4.2 y 5.0.

Si tienes un equipo con Linux instalado y necesitas saber que version de Bluetooth soporta el dispositivo (tarjeta) que tienes en tu computadora ejecuta el siguiente comando desde una terminal.

$ hciconfig -a

En mi caso retorna un mensaje como el siguiente.

hci0:	Type: Primary  Bus: USB
	BD Address: C0:F8:DA:E5:CB:4C  ACL MTU: 1021:8  SCO MTU: 64:1
	UP RUNNING PSCAN ISCAN 
	RX bytes:895 acl:0 sco:0 events:97 errors:0
	TX bytes:5473 acl:0 sco:0 commands:77 errors:0
	Features: 0xff 0xff 0x8f 0xfe 0x9b 0xff 0x79 0x87
	Packet type: DM1 DM3 DM5 DH1 DH3 DH5 HV1 HV2 HV3 
	Link policy: RSWITCH HOLD SNIFF PARK 
	Link mode: SLAVE ACCEPT 
	Name: 'ombnt18'
	Class: 0x1c010c
	Service Classes: Rendering, Capturing, Object Transfer
	Device Class: Computer, Laptop
	HCI Version: 3.0 (0x5)  Revision: 0x205
	LMP Version: 3.0 (0x5)  Subversion: 0x4203
	Manufacturer: Broadcom Corporation (15)

La linea LMP dice que mi dispositivo Bluetooth soporta la version 3.0

A %d blogueros les gusta esto: